summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYury Gribov <tetra2005@gmail.com>2018-04-27 07:40:23 +0100
committerFlorian Westphal <fw@strlen.de>2018-05-11 23:03:13 +0200
commit5087de4556d1367fad54b3ea1cd38a770a15995c (patch)
tree0e3319783e9b0799252e1bdbe46e732f918870d6 /src/Makefile.am
parent62ca426c2cfbca9be47c778e09990e9412b68bac (diff)
libnfnetlink: hide private symbols
They are: recalc_rebind_subscriptions rtnl_close rtnl_dump_type rtnl_handler_register rtnl_handler_unregister rtnl_open rtnl_parse_rtattr rtnl_receive rtnl_receive_multi Signed-off-by: Yury Gribov <tetra2005@gmail.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d0098cc..5524b0f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,9 @@ include $(top_srcdir)/Make_global.am
lib_LTLIBRARIES = libnfnetlink.la
libnfnetlink_la_LDFLAGS = -Wc,-nostartfiles \
- -version-info $(LIBVERSION)
+ -version-info $(LIBVERSION) \
+ -Wl,--version-script=$(srcdir)/nfnl.version
libnfnetlink_la_SOURCES = libnfnetlink.c iftable.c rtnl.c
+EXTRA_libnfnetlink_la_DEPENDENCIES = $(srcdir)/nfnl.version
noinst_HEADERS = iftable.h rtnl.h