summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorHarsha Sharma <harshasharmaiitr@gmail.com>2018-05-08 18:21:14 +0530
committerPablo Neira Ayuso <pablo@netfilter.org>2018-05-08 15:01:57 +0200
commit645036caa805d8189f0afeb5219b856dea5156f5 (patch)
tree1bb6aa66e89ba2374924ba8440144d83d0c525d4 /examples/Makefile.am
parentb97f45c2ebaa60ec5c3e8781937ce8ac3bba1251 (diff)
examples: Add test for assigning helper objects via rule
Usage: ./nft-rule-ct-helper-add ip filter input sip-5060 ./nft-rule-get ip filter ip filter input 7 6 [ objref type 3 name sip-5060 ] nft list ruleset ... chain input { ct helper set "sip-5060" } Signed-off-by: Harsha Sharma <harshasharmaiitr@gmail.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 96112e7..3ec699b 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -33,7 +33,8 @@ check_PROGRAMS = nft-table-add \
nft-compat-get \
nft-ct-helper-add \
nft-ct-helper-get \
- nft-ct-helper-del
+ nft-ct-helper-del \
+ nft-rule-ct-helper-add
nft_table_add_SOURCES = nft-table-add.c
nft_table_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
@@ -136,3 +137,6 @@ nft_ct_helper_get_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
nft_ct_helper_del_SOURCES = nft-ct-helper-del.c
nft_ct_helper_del_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}
+
+nft_rule_ct_helper_add_SOURCES = nft-rule-ct-helper-add.c
+nft_rule_ct_helper_add_LDADD = ../src/libnftnl.la ${LIBMNL_LIBS}