summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-06-08 17:27:19 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2018-06-11 11:31:49 +0200
commit872f373dc50f702d0956b61ddebe2357cdf04543 (patch)
tree1357490dfd2dd579ccf880d614febedf29d4a337 /configure.ac
parentf63b54623fcd1ab7d2f51928571c164409f00175 (diff)
doc: Add JSON schema documentation
The document is written as man page in asciidoc which means this adds another dependency to the build system. Though since the (long-term) plan is to replace the docbook-based nft man page with an asciidoc one anyway, we might ultimately get rid of docbook dependency in exchange. Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fdf5098a..3c5ba4db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,12 +67,22 @@ AM_COND_IF([BUILD_MAN], [
)]
)
AC_SUBST(DB2MAN)
+
+ [need_a2x=yes]
])
AM_COND_IF([BUILD_PDF], [
AC_CHECK_PROG(DBLATEX, [dblatex], [found], [no])
AS_IF([test "$DBLATEX" == "no"],
[AC_MSG_ERROR([dblatex not found])])
+
+ [need_a2x=yes]
+])
+
+AS_IF([test "$need_a2x" = "yes"], [
+ AC_CHECK_PROG(A2X, [a2x], [found], [no])
+ AS_IF([test "$A2X" != "found"],
+ [AC_MSG_ERROR([a2x not found])])
])
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])