summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Leblond <eric@regit.org>2012-11-03 11:41:39 +0100
committerEric Leblond <eric@regit.org>2012-11-04 08:58:10 +0100
commit53aa4c9beef7156bb3de09240203a89b79c3aee7 (patch)
treeda23de32a5f3d675638bd36df3d3df2daf8e5cd1 /configure.ac
parentd75255d2ad835c41c091f466962ade08067f26c5 (diff)
configure: add flag to disable NFLOG build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5bb8644..930aef0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,7 +44,13 @@ AC_SUBST([regular_CFLAGS])
dnl Check for the right nfnetlink version
PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 1.0.1])
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
-PKG_CHECK_MODULES([LIBNETFILTER_LOG], [libnetfilter_log >= 1.0.0])
+AC_ARG_ENABLE(nflog,
+ AS_HELP_STRING([--enable-nflog], [Enable nflog module [default=yes]]),,[enable_nflog=yes])
+AS_IF([test "x$enable_nflog" = "xyes"], [
+ PKG_CHECK_MODULES([LIBNETFILTER_LOG], [libnetfilter_log >= 1.0.0])
+ AC_DEFINE([BUILD_NFLOG], [1], [Building nflog module])
+])
+AM_CONDITIONAL([BUILD_NFLOG], [test "x$enable_nflog" = "xyes"])
AC_ARG_ENABLE(nfct,
AS_HELP_STRING([--enable-nfct], [Enable nfct module [default=yes]]),,[enable_nfct=yes])
AS_IF([test "x$enable_nfct" = "xyes"], [