summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Leblond <eric@regit.org>2015-04-24 21:44:58 +0200
committerEric Leblond <eric@regit.org>2015-04-24 21:53:54 +0200
commit587dcba946b0a4a1e763940353afff68ee3ea1ba (patch)
treec2d53244c0d1a2b7659037f5b68c6bd84e23e189 /configure.ac
parent2ef76b685b0cfa16ec73ece0722f78bf6084a06c (diff)
Add flag to disable ULOG input plugin
ULOG target is removed from kernel so we can prepare the removal of the plugin for ulogd. For now, we just add a configure flag.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7c1654..df93f72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,13 @@ AC_SUBST([regular_CFLAGS])
AC_SEARCH_LIBS([pthread_create], [pthread], [libpthread_LIBS="$LIBS"; LIBS=""])
AC_SUBST([libpthread_LIBS])
+AC_ARG_ENABLE(ulog,
+ AS_HELP_STRING([--enable-ulog], [Enable ulog module [default=yes]]),[enable_ulog=$enableval],[enable_ulog=yes])
+AM_CONDITIONAL([BUILD_ULOG], [test "x$enable_ulog" = "xyes"])
+if [! test "x$enable_ulog" = "xyes"]; then
+ enable_ulog="no"
+fi
+
dnl Check for the right nfnetlink version
PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 1.0.1])
AC_ARG_ENABLE(nflog,
@@ -157,6 +164,7 @@ Ulogd configuration:
NFLOG plugin: ${enable_nflog}
NFCT plugin: ${enable_nfct}
NFACCT plugin: ${enable_nfacct}
+ ULOG plugin: ${enable_ulog}
Output plugins:
PCAP plugin: ${enable_pcap}
PGSQL plugin: ${enable_pgsql}