summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorlaforge <laforge>2003-07-15 12:18:50 +0000
committerlaforge <laforge>2003-07-15 12:18:50 +0000
commit409e20519fcf503cbfdbb8a6db3446aa7fff3742 (patch)
tree35eeb8e4e18eb8b3120c8ccf5d296defeb0c3c9c /configure.in
parent7242913eb71a31b229ad6e42130fc9c10a53e1d7 (diff)
check for more posgresql include paths (supposedly fixes problem with rh7.2)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 39d3eda..5d0d99b 100644
--- a/configure.in
+++ b/configure.in
@@ -159,13 +159,14 @@ then
AC_MSG_WARN(PGSQL backend not used)
else
AC_DEFINE(HAVE_PGSQL)
- if test -f ${pgsqldir}/include/libpq-fe.h
- then
- PGSQLINCLUDES=${pgsqldir}/include
- elif test -f ${pgsqldir}/include/postgresql/libpq-fe.h
- then
- PGSQLINCLUDES=${pgsqldir}/include/postgresql
- fi
+ for i in include include/postgresql include/pgsql
+ do
+ if test -f ${pgsqldir}/$i/libpq-fe.h
+ then
+ PGSQLINCLUDES=${pgsqldir}/$i
+ break
+ fi
+ done
PGSQLLIBS=${pgsqldir}/lib
DATABASE_DIR="${DATABASE_DIR} pgsql"