summaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-02-01 02:56:49 +0100
committerJan Engelhardt <jengelh@medozas.de>2011-02-01 02:58:45 +0100
commit3011dcf8a1ea426ef2a07f528430ee6219ddf401 (patch)
treeddaea2640844e3eb1e7b69bedd9fbf9c5814b7b8 /filter/Makefile.am
parent422c5ece0242f7863737ddee703c88529b165ba9 (diff)
build: use compile/link information from pkgconfig
This is important for when the libraries are in a non-default path. Also, libs must be listed in LDADD/LIBADD, not LDFLAGS. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
index 83a0e52..ee0a722 100644
--- a/filter/Makefile.am
+++ b/filter/Makefile.am
@@ -1,7 +1,7 @@
SUBDIRS = raw2packet packet2flow
AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CFLAGS = ${regular_CFLAGS}
+AM_CFLAGS = ${regular_CFLAGS} ${LIBNFNETLINK_CFLAGS}
pkglibexec_LTLIBRARIES = ulogd_filter_IFINDEX.la ulogd_filter_PWSNIFF.la \
ulogd_filter_PRINTPKT.la ulogd_filter_PRINTFLOW.la \
@@ -9,7 +9,8 @@ pkglibexec_LTLIBRARIES = ulogd_filter_IFINDEX.la ulogd_filter_PWSNIFF.la \
ulogd_filter_HWHDR.la ulogd_filter_MARK.la
ulogd_filter_IFINDEX_la_SOURCES = ulogd_filter_IFINDEX.c
-ulogd_filter_IFINDEX_la_LDFLAGS = -avoid-version -module -lnfnetlink
+ulogd_filter_IFINDEX_la_LDFLAGS = -avoid-version -module
+ulogd_filter_IFINDEX_la_LIBADD = ${LIBNFNETLINK_LIBS}
ulogd_filter_PWSNIFF_la_SOURCES = ulogd_filter_PWSNIFF.c
ulogd_filter_PWSNIFF_la_LDFLAGS = -avoid-version -module