summaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
authorEric Leblond <eric@inl.fr>2008-06-12 11:08:31 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2008-06-12 11:08:31 +0200
commitda35b9e971b852338be7bbb00c639a381b1a5a76 (patch)
tree2839c5a55cb30861c961d42c2c7c685bef2b9f4b /filter/Makefile.am
parent509bf34f1843203cdaa21bfbdb88212ab8de8c8f (diff)
New MARK-based filter
This module filters message by using the mark to decide wether or not a packet or a flow has to be logged. It takes a mark and a mask option. It demonstrates the usage of ULOGD_IRET_STOP which can be used to abort iteration through the stack. Signed-off-by: Eric Leblond <eric@inl.fr>
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
index 958a5de..cbeb5bc 100644
--- a/filter/Makefile.am
+++ b/filter/Makefile.am
@@ -5,7 +5,7 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
pkglib_LTLIBRARIES = ulogd_filter_IFINDEX.la ulogd_filter_PWSNIFF.la \
ulogd_filter_PRINTPKT.la ulogd_filter_PRINTFLOW.la \
ulogd_filter_IP2STR.la ulogd_filter_IP2BIN.la \
- ulogd_filter_MAC2STR.la
+ ulogd_filter_MAC2STR.la ulogd_filter_MARK.la
ulogd_filter_IFINDEX_la_SOURCES = ulogd_filter_IFINDEX.c
ulogd_filter_IFINDEX_la_LDFLAGS = -module -lnfnetlink
@@ -22,6 +22,9 @@ ulogd_filter_IP2BIN_la_LDFLAGS = -module
ulogd_filter_MAC2STR_la_SOURCES = ulogd_filter_MAC2STR.c
ulogd_filter_MAC2STR_la_LDFLAGS = -module
+ulogd_filter_MARK_la_SOURCES = ulogd_filter_MARK.c
+ulogd_filter_MARK_la_LDFLAGS = -module
+
ulogd_filter_PRINTPKT_la_SOURCES = ulogd_filter_PRINTPKT.c ../util/printpkt.c
ulogd_filter_PRINTPKT_la_LDFLAGS = -module