summaryrefslogtreecommitdiffstats
path: root/input/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-11-14 15:52:24 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2021-11-15 11:42:41 +0100
commit7994d971798b957fd3dd686f48c71c8725bf703e (patch)
tree5f9598aec58508f2b191aaa02d4d118d2c2da8bd /input/Makefile.am
parent6cc4b5a9968708178989c850177ffd734c2b9eae (diff)
build: skip sub-directories containing disabled plugins
Currently, make enters all sub-directories containing source-code, even if they only contain optional targets which are not configured to be built. Instead, change the Makefiles so that the sub-directories are optional, rather than the targets. Group sub-directory definitions consistently at the top of the Makefiles that contain them. Trim a few leading and trailing blank lines. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'input/Makefile.am')
-rw-r--r--input/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/input/Makefile.am b/input/Makefile.am
index 5ffef1b..668fc2b 100644
--- a/input/Makefile.am
+++ b/input/Makefile.am
@@ -1,2 +1,9 @@
+if BUILD_NFCT
+ OPT_SUBDIR_FLOW = flow
+endif
-SUBDIRS = packet flow sum
+if BUILD_NFACCT
+ OPT_SUBDIR_SUM = sum
+endif
+
+SUBDIRS = packet $(OPT_SUBDIR_FLOW) $(OPT_SUBDIR_SUM)