summaryrefslogtreecommitdiffstats
path: root/output/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-11-14 15:52:22 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2021-11-15 11:42:41 +0100
commit6056f33fd46e5964ff9fd82cb88de213b4174642 (patch)
tree1aee78f1dbe8dbb661466afd4509918a794d9480 /output/Makefile.am
parent820438083eb04abf8efc722fbbe0fdab7c88163d (diff)
build: add Make_global.am for common flags
Move `${regular_CFLAGS}` from configure.ac to Make_global.am, renaming it to `AM_CFLAGS`. Add `AM_CPPFGLAGS` to include `$(top_srcdir)/include`. Include the new file in the Makefiles that require it. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'output/Makefile.am')
-rw-r--r--output/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/output/Makefile.am b/output/Makefile.am
index 7ba8217..879c317 100644
--- a/output/Makefile.am
+++ b/output/Makefile.am
@@ -1,6 +1,8 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include ${LIBNETFILTER_ACCT_CFLAGS} \
- ${LIBNETFILTER_CONNTRACK_CFLAGS} ${LIBNETFILTER_LOG_CFLAGS}
-AM_CFLAGS = ${regular_CFLAGS}
+include $(top_srcdir)/Make_global.am
+
+AM_CPPFLAGS += ${LIBNETFILTER_ACCT_CFLAGS} \
+ ${LIBNETFILTER_CONNTRACK_CFLAGS} \
+ ${LIBNETFILTER_LOG_CFLAGS}
SUBDIRS= pcap mysql pgsql sqlite3 dbi ipfix