summaryrefslogtreecommitdiffstats
path: root/output/mysql/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-02-01 02:41:27 +0100
committerJan Engelhardt <jengelh@medozas.de>2011-02-01 02:51:54 +0100
commitbf85255e1c813ef208eee77079f14eb5ebe766de (patch)
tree7a74599e116ea53cf6a40bf31cb516b08e549682 /output/mysql/Makefile.am
parent6c21436c119cd7ba053937229aeb09dfd25925c2 (diff)
build: avoid use of LIBS variable
The variable contains global libraries linked into every possible object, which is unwanted. Clean up things. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'output/mysql/Makefile.am')
-rw-r--r--output/mysql/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/output/mysql/Makefile.am b/output/mysql/Makefile.am
index a98cdeb..c24208c 100644
--- a/output/mysql/Makefile.am
+++ b/output/mysql/Makefile.am
@@ -1,12 +1,12 @@
AM_CPPFLAGS = -I$(top_srcdir)/include $(MYSQL_INC)
AM_CFLAGS = ${regular_CFLAGS}
-LIBS=$(MYSQL_LIB)
if HAVE_MYSQL
pkglib_LTLIBRARIES = ulogd_output_MYSQL.la
ulogd_output_MYSQL_la_SOURCES = ulogd_output_MYSQL.c ../../util/db.c
+ulogd_output_MYSQL_la_LIBADD = ${MYSQL_LIB}
ulogd_output_MYSQL_la_LDFLAGS = -avoid-version -module
endif