summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-11-14 15:52:21 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2021-11-15 11:42:41 +0100
commit820438083eb04abf8efc722fbbe0fdab7c88163d (patch)
treea76f2b7e8223f23fe2f0c513db8124db6aaaf110 /src/Makefile.am
parentf3ff1d5f335be62918224deba36f9eb592a7b27d (diff)
build: move CPP `-D` flag.
The `ULOGD2_LIBDIR` macro is only used in one place, so move the flag defining it out of the common `regular_CFLAGS` variable to the `AM_CPPFLAGS` variable in the Makefile where it is needed. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 998e776..e1d45ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,8 @@
AM_CPPFLAGS = -I$(top_srcdir)/include \
- -DULOGD_CONFIGFILE="\"$(sysconfdir)/ulogd.conf\"" \
- -DULOGD_LOGFILE_DEFAULT="\"$(localstatedir)/log/ulogd.log\""
+ -DULOGD_CONFIGFILE='"$(sysconfdir)/ulogd.conf"' \
+ -DULOGD_LOGFILE_DEFAULT='"$(localstatedir)/log/ulogd.log"' \
+ -DULOGD2_LIBDIR='"$(ulogd2libdir)"'
AM_CFLAGS = ${regular_CFLAGS}
sbin_PROGRAMS = ulogd