summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2013-05-02 10:51:55 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2013-05-02 10:51:55 +0200
commit18149c6ac307e089abe3dcc078fc3fccf6afc4c6 (patch)
tree8392b520773d700c876a218efdb5c9c176749d95 /Makefile.am
parentf535c61dc1e3e77ad4b5eefe4f6696514e8cf58d (diff)
Add sparse checking support to userspace
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0806623..3453604 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,11 +17,15 @@ endif
SUBDIRS = include/libipset lib src
+sparse-check:
+ $(MAKE) -C lib sparse-check
+ $(MAKE) -C src sparse-check
+
modules_sparse:
if WITH_KMOD
${MAKE} -C $(KBUILD_OUTPUT) M=$$PWD/kernel/net/netfilter \
- V=$V C=2 CF=-D__CHECK_ENDIAN__ \
- KCFLAGS="-DPACKAGE_VERSION=$(PACKAGE_VERSION)" \
+ V=$V W=1 C=2 CF="-D__CHECK_ENDIAN__ -Wsparse-all" \
+ KCFLAGS="-DPACKAGE_VERSION=$(PACKAGE_VERSION) -DCHECK_KCONFIG -Wextra" \
IP_SET_MAX=$(IP_SET_MAX) KDIR=$$PWD/kernel modules
else
@echo Skipping kernel modules due to --with-kmod=no