summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-07-29 19:04:34 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2008-07-29 19:04:34 +0200
commitce5e35f466c4e1168b7f4b11bf7d9f8e6516e920 (patch)
tree96c4e563f38b1b36f10f684304fdb175c485921b /configure.ac
parent72ed4ffedd4ea97faf1e405e90f512f881c59386 (diff)
parent675e30f258952292972a562b71161b6d3cd77313 (diff)
Merge branch 'master' of vishnu.netfilter.org:/data/git/iptables
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index ce26e28c..2ffe6c02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
define([_XTABLES_VERSION_MAJOR], 1)
define([_XTABLES_VERSION_MINOR], 4)
-define([_XTABLES_VERSION_PATCH], 1)
-define([_XTABLES_VERSION_EXTRA], .1)
+define([_XTABLES_VERSION_PATCH], 2)
+define([_XTABLES_VERSION_EXTRA], -rc1)
define([_XTABLES_VERSION],_XTABLES_VERSION_MAJOR._XTABLES_VERSION_MINOR._XTABLES_VERSION_PATCH[]_XTABLES_VERSION_EXTRA)
@@ -38,7 +38,6 @@ AC_ARG_ENABLE([devel],
AC_ARG_ENABLE([libipq],
AS_HELP_STRING([--enable-libipq], [Build and install libipq]))
-AC_CHECK_HEADER([netinet/ip6.h], [], [AC_MSG_ERROR(but we need that for IPv6)])
AC_CHECK_HEADER([linux/dccp.h])
blacklist_modules="";
@@ -47,10 +46,10 @@ if test "$ac_cv_header_linux_dccp_h" != "yes"; then
fi;
AC_SUBST([blacklist_modules])
-AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" == "yes"])
-AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" == "yes"])
-AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" == "yes"])
-AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" == "yes"])
+AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" = "yes"])
+AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" = "yes"])
+AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
+AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
regular_CFLAGS="-D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 \
-D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \