summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-09-08 16:07:16 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-09-08 16:07:16 +0200
commit891d5790b3f4caeed80f1449d280617c54df8837 (patch)
tree6328d4a4a0d4bffb76fc5ecf297b4386a1257191 /iptables/Makefile.am
parentbf42cf92ea0c53e5470a20d62d00e5e83379f4d5 (diff)
parent153c23d9b14285b24aae3e96da0b547dcc7ee051 (diff)
Merge branch 'stable'
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index addb1598..af620f76 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -6,17 +6,21 @@ AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}
lib_LTLIBRARIES = libxtables.la
libxtables_la_SOURCES = xtables.c xtoptions.c
libxtables_la_LDFLAGS = -version-info ${libxtables_vcurrent}:0:${libxtables_vage}
+libxtables_la_LIBADD =
+if ENABLE_STATIC
+# With --enable-static, shipped extensions are linked into the main executable,
+# so we need all the LIBADDs here too
+libxtables_la_LIBADD += -lm
+endif
if ENABLE_SHARED
libxtables_la_CFLAGS = ${AM_CFLAGS}
-libxtables_la_LIBADD = -ldl
+libxtables_la_LIBADD += -ldl
else
libxtables_la_CFLAGS = ${AM_CFLAGS} -DNO_SHARED_LIBS=1
-libxtables_la_LIBADD =
endif
xtables_multi_SOURCES = xtables-multi.c iptables-xml.c
xtables_multi_CFLAGS = ${AM_CFLAGS}
-xtables_multi_LDFLAGS = -rdynamic
xtables_multi_LDADD = ../extensions/libext.a
if ENABLE_STATIC
xtables_multi_CFLAGS += -DALL_INCLUSIVE