summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index b023755..f95b268 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to create configure.
-AC_INIT([libnftables], [1.0.0])
+AC_INIT([libnftnl], [1.0.0])
AC_CONFIG_AUX_DIR([build-aux])
AC_CANONICAL_HOST
AC_CONFIG_MACRO_DIR([m4])
@@ -16,18 +16,18 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
dnl Dependencies
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.0])
AC_ARG_WITH([xml-parsing],
- AS_HELP_STRING([--with-xml-parsing], [XML parsing support]),
- [with_xml_parsing="yes"], [with_xml_parsing="no"])
+ AS_HELP_STRING([--with-xml-parsing], [XML parsing support]))
AC_ARG_WITH([json-parsing],
- AS_HELP_STRING([--with-json-parsing], [JSON parsing support]),
- [with_json_parsing="yes"], [with_json_parsing="no"])
-
-AS_IF([test "x$with_xml_parsing" = "xyes"], [
- PKG_CHECK_MODULES([LIBXML], [mxml >= 2.6])
-])
-AS_IF([test "x$with_json_parsing" = "xyes"], [
- PKG_CHECK_MODULES([LIBJSON], [jansson >= 2.3])
-])
+ AS_HELP_STRING([--with-json-parsing], [JSON parsing support]))
+
+AS_IF([test "x$with_xml_parsing" = "xyes"],
+ [PKG_CHECK_MODULES([LIBXML], [mxml >= 2.6])],
+ [with_xml_parsing="no"]
+)
+AS_IF([test "x$with_json_parsing" = "xyes"],
+ [PKG_CHECK_MODULES([LIBJSON], [jansson >= 2.3])],
+ [with_json_parsing="no"]
+)
AC_PROG_CC
AM_PROG_CC_C_O
AC_EXEEXT
@@ -52,10 +52,10 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
-Wformat=2 -pipe"
AC_SUBST([regular_CPPFLAGS])
AC_SUBST([regular_CFLAGS])
-AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libnftables/Makefile include/linux/Makefile include/linux/netfilter/Makefile examples/Makefile tests/Makefile libnftables.pc doxygen.cfg])
+AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libnftnl/Makefile include/linux/Makefile include/linux/netfilter/Makefile examples/Makefile tests/Makefile libnftnl.pc doxygen.cfg])
AC_OUTPUT
echo "
-libnftables configuration:
+libnftnl configuration:
XML support: ${with_xml_parsing}
JSON support: ${with_json_parsing}"