summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2023-10-19 15:00:02 +0200
committerFlorian Westphal <fw@strlen.de>2023-11-02 11:48:30 +0100
commit89554fe9ef1d29714d7f678dbcc6544af74adf29 (patch)
tree9c7397f6eab06e4c83d6e01094b9d9dec31c5e12 /Makefile.am
parent686d987706bf643f2fa75c1993a5720ad55e6df1 (diff)
build: no recursive make for "py/Makefile.am"
Merge the Makefile.am under "py/" into the toplevel Makefile.am. This is a step in the effort of dropping recursive make. Signed-off-by: Thomas Haller <thaller@redhat.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index bfc64ebb..8b8de7bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
+EXTRA_DIST =
+
pkginclude_HEADERS = \
include/nftables/libnftables.h \
$(NULL)
@@ -73,11 +75,21 @@ noinst_HEADERS = \
SUBDIRS = src \
files \
doc \
- examples\
- py
+ examples
+
+EXTRA_DIST += \
+ py/pyproject.toml \
+ py/setup.cfg \
+ py/setup.py \
+ py/src/__init__.py \
+ py/src/nftables.py \
+ py/src/schema.json \
+ $(NULL)
-EXTRA_DIST = tests \
- files
+EXTRA_DIST += \
+ files \
+ tests \
+ $(NULL)
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libnftables.pc