summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2023-10-19 15:00:05 +0200
committerFlorian Westphal <fw@strlen.de>2023-11-02 11:48:30 +0100
commitc96e0a17f369987332ee33746c44ea0133e6d49c (patch)
tree7ce6c16a91c853dd98184b31e4e063e8b400bae5 /Makefile.am
parent11e62138424ad7c1f1c80345e1f9f54599651c58 (diff)
build: no recursive make for "examples/Makefile.am"
Merge the Makefile.am under "examples/" into the toplevel Makefile.am. This is a step in the effort of dropping recursive make. Signed-off-by: Thomas Haller <thaller@redhat.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b89d60e3..af82f021 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,9 +26,11 @@ ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST =
BUILT_SOURCES =
+LDADD =
lib_LTLIBRARIES =
noinst_LTLIBRARIES =
sbin_PROGRAMS =
+check_PROGRAMS =
###############################################################################
@@ -288,9 +290,20 @@ src_nft_LDADD = src/libnftables.la
###############################################################################
-SUBDIRS = \
- doc \
- examples
+SUBDIRS = doc
+
+###############################################################################
+
+
+check_PROGRAMS += examples/nft-buffer
+
+examples_nft_buffer_AM_CPPFLAGS = -I$(srcdir)/include
+examples_nft_buffer_LDADD = src/libnftables.la
+
+check_PROGRAMS += examples/nft-json-file
+
+examples_nft_json_file_AM_CPPFLAGS = -I$(srcdir)/include
+examples_nft_json_file_LDADD = src/libnftables.la
###############################################################################