summaryrefslogtreecommitdiffstats
path: root/output/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-11-14 15:52:24 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2021-11-15 11:42:41 +0100
commit7994d971798b957fd3dd686f48c71c8725bf703e (patch)
tree5f9598aec58508f2b191aaa02d4d118d2c2da8bd /output/Makefile.am
parent6cc4b5a9968708178989c850177ffd734c2b9eae (diff)
build: skip sub-directories containing disabled plugins
Currently, make enters all sub-directories containing source-code, even if they only contain optional targets which are not configured to be built. Instead, change the Makefiles so that the sub-directories are optional, rather than the targets. Group sub-directory definitions consistently at the top of the Makefiles that contain them. Trim a few leading and trailing blank lines. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'output/Makefile.am')
-rw-r--r--output/Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/output/Makefile.am b/output/Makefile.am
index 879c317..cdb49df 100644
--- a/output/Makefile.am
+++ b/output/Makefile.am
@@ -1,11 +1,36 @@
+if HAVE_PCAP
+ OPT_SUBDIR_PCAP = pcap
+endif
+
+if HAVE_MYSQL
+ OPT_SUBDIR_MYSQL = mysql
+endif
+
+if HAVE_PGSQL
+ OPT_SUBDIR_PGSQL = pgsql
+endif
+
+if HAVE_SQLITE3
+ OPT_SUBDIR_SQLITE3 = sqlite3
+endif
+
+if HAVE_DBI
+ OPT_SUBDIR_DBI = dbi
+endif
+
+SUBDIRS = $(OPT_SUBDIR_PCAP) \
+ $(OPT_SUBDIR_MYSQL) \
+ $(OPT_SUBDIR_PGSQL) \
+ $(OPT_SUBDIR_SQLITE3) \
+ $(OPT_SUBDIR_DBI) \
+ ipfix
+
include $(top_srcdir)/Make_global.am
AM_CPPFLAGS += ${LIBNETFILTER_ACCT_CFLAGS} \
${LIBNETFILTER_CONNTRACK_CFLAGS} \
${LIBNETFILTER_LOG_CFLAGS}
-SUBDIRS= pcap mysql pgsql sqlite3 dbi ipfix
-
pkglib_LTLIBRARIES = ulogd_output_LOGEMU.la ulogd_output_SYSLOG.la \
ulogd_output_OPRINT.la ulogd_output_GPRINT.la \
ulogd_output_NACCT.la ulogd_output_XML.la \