summaryrefslogtreecommitdiffstats
path: root/output/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'output/Makefile.am')
-rw-r--r--output/Makefile.am35
1 files changed, 31 insertions, 4 deletions
diff --git a/output/Makefile.am b/output/Makefile.am
index 7ba8217..cdb49df 100644
--- a/output/Makefile.am
+++ b/output/Makefile.am
@@ -1,8 +1,35 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include ${LIBNETFILTER_ACCT_CFLAGS} \
- ${LIBNETFILTER_CONNTRACK_CFLAGS} ${LIBNETFILTER_LOG_CFLAGS}
-AM_CFLAGS = ${regular_CFLAGS}
+if HAVE_PCAP
+ OPT_SUBDIR_PCAP = pcap
+endif
+
+if HAVE_MYSQL
+ OPT_SUBDIR_MYSQL = mysql
+endif
+
+if HAVE_PGSQL
+ OPT_SUBDIR_PGSQL = pgsql
+endif
+
+if HAVE_SQLITE3
+ OPT_SUBDIR_SQLITE3 = sqlite3
+endif
+
+if HAVE_DBI
+ OPT_SUBDIR_DBI = dbi
+endif
+
+SUBDIRS = $(OPT_SUBDIR_PCAP) \
+ $(OPT_SUBDIR_MYSQL) \
+ $(OPT_SUBDIR_PGSQL) \
+ $(OPT_SUBDIR_SQLITE3) \
+ $(OPT_SUBDIR_DBI) \
+ ipfix
+
+include $(top_srcdir)/Make_global.am
-SUBDIRS= pcap mysql pgsql sqlite3 dbi ipfix
+AM_CPPFLAGS += ${LIBNETFILTER_ACCT_CFLAGS} \
+ ${LIBNETFILTER_CONNTRACK_CFLAGS} \
+ ${LIBNETFILTER_LOG_CFLAGS}
pkglib_LTLIBRARIES = ulogd_output_LOGEMU.la ulogd_output_SYSLOG.la \
ulogd_output_OPRINT.la ulogd_output_GPRINT.la \