summaryrefslogtreecommitdiffstats
path: root/libxtables/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-09-19 13:44:18 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-09-19 13:44:18 +0200
commit134280881a3c99f313da669117de71bc236f1f77 (patch)
tree8d83c4dd01be6a6cd7de356c969785474c5cdc4d /libxtables/Makefile.am
parent0ab10b11093ec250b404e3bead1d39177d1cbfa0 (diff)
parentd2b0eaa297dfa87f54b3fbcaa292f14d793e3f3c (diff)
Merge branch 'stable'
Diffstat (limited to 'libxtables/Makefile.am')
-rw-r--r--libxtables/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/libxtables/Makefile.am b/libxtables/Makefile.am
new file mode 100644
index 00000000..c5795fef
--- /dev/null
+++ b/libxtables/Makefile.am
@@ -0,0 +1,20 @@
+# -*- Makefile -*-
+
+AM_CFLAGS = ${regular_CFLAGS}
+AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}/include -I${top_srcdir}/iptables ${kinclude_CPPFLAGS}
+
+lib_LTLIBRARIES = libxtables.la
+libxtables_la_SOURCES = xtables.c xtoptions.c
+libxtables_la_LDFLAGS = -version-info ${libxtables_vcurrent}:0:${libxtables_vage}
+libxtables_la_LIBADD =
+if ENABLE_STATIC
+# With --enable-static, shipped extensions are linked into the main executable,
+# so we need all the LIBADDs here too
+libxtables_la_LIBADD += -lm
+endif
+if ENABLE_SHARED
+libxtables_la_CFLAGS = ${AM_CFLAGS}
+libxtables_la_LIBADD += -ldl
+else
+libxtables_la_CFLAGS = ${AM_CFLAGS} -DNO_SHARED_LIBS=1
+endif