summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-12-30 16:38:32 +0100
committerJan Engelhardt <jengelh@medozas.de>2010-12-31 00:19:51 +0100
commita0b68d260f04776f021e8117ba4d88bcc5c70b9a (patch)
tree6fff87923de6b390783d8e953096818c530539e9 /configure.ac
parent091286e666a9d34818a875152ac7659b38656f06 (diff)
build: use AM_CPPFLAGS
Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 264242a..819cbf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,10 +17,11 @@ case $target in
*) AC_MSG_ERROR([Linux only, dude!]);;
esac
-regular_CFLAGS="-D_FILE_OFFSET_BITS=64 \
- -D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \
+regular_CPPFLAGS="-D_FILE_OFFSET_BITS=64 -D_REENTRANT"
+regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes \
-Wformat=2 -pipe"
+AC_SUBST([regular_CPPFLAGS])
AC_SUBST([regular_CFLAGS])
AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libmnl/Makefile include/linux/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg])
AC_OUTPUT