summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCristian Rodríguez <cristian.rodriguez@opensuse.org>2010-11-15 20:31:25 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2010-11-15 20:31:25 +0100
commit37dac00e2ad6445f496e68fcf815723432ecb5a8 (patch)
tree9c97e3f99a1663970c578ad879903ced82277415 /src/Makefile.am
parent485d30a8a89e7500b0df4291fa4dfc33b894998c (diff)
src: implement both GCC visibility support and export script
Read "How to write shared libraries" from Ulrich Drepper for more information on this patch. Specifically section 2.2: Export control and section 3: Maintaining APIs and ABIs. Signed-off-by: Cristian Rodríguez <cristian.rodriguez@opensuse.org> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 064ccf5..dd1b1b7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,7 @@
include $(top_srcdir)/Make_global.am
-
+AM_CFLAGS += $(CFLAG_VISIBILITY)
+AM_CPPFLAGS += -DBUILDING_MNL
lib_LTLIBRARIES = libmnl.la
-libmnl_la_LDFLAGS = -version-info $(LIBVERSION)
+libmnl_la_LDFLAGS = -Wl,--version-script=$(srcdir)/libmnl.map -version-info $(LIBVERSION)
libmnl_la_SOURCES = socket.c callback.c nlmsg.c attr.c