summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-07 02:12:35 +0000
committerPhil Sutter <phil@nwl.cc>2024-02-07 18:10:43 +0100
commit02466e17e8cca5f97757092094c0600cedce09e2 (patch)
treec6b799aaa736f914c9394236943a6bbb03ebe7f5 /Makefile.am
parent9f76bb63c0c706ea5c0d55931ee690ca5dccaf16 (diff)
Makefile.am: don't silence -Wimplicit-function-declaration
This becomes an error in GCC 14 and Clang 16. It's a common misconception that these warnings are invalid or simply noise for Bison/parser files, but even if that were true, we'd need to handle it somehow anyway. Silencing them does nothing, so stop doing that. Further, I don't actually get any warnings to fix with bison-3.8.2. This mirrors changes we've done in other netfilter.org projects. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Phil Sutter <phil@nwl.cc>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ed831a1..688a9849 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,7 +170,6 @@ src_libparser_la_SOURCES = \
src_libparser_la_CFLAGS = \
$(AM_CFLAGS) \
- -Wno-implicit-function-declaration \
-Wno-missing-declarations \
-Wno-missing-prototypes \
-Wno-nested-externs \