summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2023-10-19 15:00:06 +0200
committerFlorian Westphal <fw@strlen.de>2023-11-02 11:48:30 +0100
commite6f21c85f2cac9e7d5437b68de470da0e4180b60 (patch)
tree07df2136d857bbac821df19c6e1e79888808191a /Makefile.am
parentc96e0a17f369987332ee33746c44ea0133e6d49c (diff)
build: no recursive make for "doc/Makefile.am"
Merge the Makefile.am under "doc/" into the toplevel Makefile.am. This is a step in the effort of dropping recursive make. Signed-off-by: Thomas Haller <thaller@redhat.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am60
1 files changed, 55 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index af82f021..0ed831a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,6 +31,8 @@ lib_LTLIBRARIES =
noinst_LTLIBRARIES =
sbin_PROGRAMS =
check_PROGRAMS =
+dist_man_MANS =
+CLEANFILES =
###############################################################################
@@ -290,11 +292,6 @@ src_nft_LDADD = src/libnftables.la
###############################################################################
-SUBDIRS = doc
-
-###############################################################################
-
-
check_PROGRAMS += examples/nft-buffer
examples_nft_buffer_AM_CPPFLAGS = -I$(srcdir)/include
@@ -307,6 +304,59 @@ examples_nft_json_file_LDADD = src/libnftables.la
###############################################################################
+if BUILD_MAN
+
+dist_man_MANS += \
+ doc/nft.8 \
+ doc/libnftables-json.5 \
+ doc/libnftables.3 \
+ $(NULL)
+
+A2X_OPTS_MANPAGE = \
+ -L \
+ --doctype manpage \
+ --format manpage \
+ -D "${builddir}/doc" \
+ $(NULL)
+
+ASCIIDOC_MAIN = doc/nft.txt
+
+ASCIIDOC_INCLUDES = \
+ doc/data-types.txt \
+ doc/payload-expression.txt \
+ doc/primary-expression.txt \
+ doc/stateful-objects.txt \
+ doc/statements.txt \
+ $(NULL)
+
+ASCIIDOCS = \
+ $(ASCIIDOC_MAIN) \
+ $(ASCIIDOC_INCLUDES) \
+ $(NULL)
+
+EXTRA_DIST += \
+ $(ASCIIDOCS) \
+ doc/libnftables-json.adoc \
+ doc/libnftables.adoc \
+ $(NULL)
+
+CLEANFILES += doc/*~
+
+doc/nft.8: $(ASCIIDOCS)
+ $(AM_V_GEN)$(A2X) $(A2X_OPTS_MANPAGE) $<
+
+.adoc.3:
+ $(AM_V_GEN)$(A2X) $(A2X_OPTS_MANPAGE) $<
+
+.adoc.5:
+ $(AM_V_GEN)$(A2X) $(A2X_OPTS_MANPAGE) $<
+
+MAINTAINERCLEANFILES = ${dist_man_MANS}
+
+endif
+
+###############################################################################
+
dist_pkgdata_DATA = \
files/nftables/all-in-one.nft \
files/nftables/arp-filter.nft \