summaryrefslogtreecommitdiffstats
path: root/py/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2023-07-18 14:01:19 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2023-07-31 09:06:22 +0200
commitb3def33efecb2f7be39fc9aefc9546907202056c (patch)
tree0c9df00a5e786507b558ce6a271928a0d83b3fee /py/Makefile.am
parent52c200b490d806da47d1f30448470e202e97f635 (diff)
py: remove setup.py integration with autotools
With Python distutils and setuptools going deprecated, remove integration with autotools. This integration is causing issues in modern environments. Note that setup.py is still left in place under the py/ folder. Update INSTALL file to refer to Python support and setup.py. Acked-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/Makefile.am')
-rw-r--r--py/Makefile.am27
1 files changed, 0 insertions, 27 deletions
diff --git a/py/Makefile.am b/py/Makefile.am
index 215ecd9e..f10ae360 100644
--- a/py/Makefile.am
+++ b/py/Makefile.am
@@ -1,28 +1 @@
EXTRA_DIST = setup.py __init__.py nftables.py schema.json
-
-all-local:
- cd $(srcdir) && \
- $(PYTHON_BIN) setup.py build --build-base $(abs_builddir)
-
-install-exec-local:
- cd $(srcdir) && \
- $(PYTHON_BIN) setup.py build --build-base $(abs_builddir) \
- install --prefix $(DESTDIR)$(prefix)
-
-uninstall-local:
- rm -rf $(DESTDIR)$(prefix)/lib*/python*/site-packages/nftables
- rm -rf $(DESTDIR)$(prefix)/lib*/python*/dist-packages/nftables
- rm -rf $(DESTDIR)$(prefix)/lib*/python*/site-packages/nftables-[0-9]*.egg-info
- rm -rf $(DESTDIR)$(prefix)/lib*/python*/dist-packages/nftables-[0-9]*.egg-info
- rm -rf $(DESTDIR)$(prefix)/lib*/python*/site-packages/nftables-[0-9]*.egg
- rm -rf $(DESTDIR)$(prefix)/lib*/python*/dist-packages/nftables-[0-9]*.egg
-
-clean-local:
- cd $(srcdir) && \
- $(PYTHON_BIN) setup.py clean \
- --build-base $(abs_builddir)
- rm -rf scripts-* lib* build dist bdist.* nftables.egg-info
- find . -name \*.pyc -delete
-
-distclean-local:
- rm -f version