summaryrefslogtreecommitdiffstats
path: root/py/setup.py
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2023-07-31 12:40:22 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2023-08-03 09:47:49 +0200
commitce443afc214553b9fa6f02a640a3cd2f71a23ec9 (patch)
tree32537f3e7e431c7d312fda2e3411a6362799ed09 /py/setup.py
parent76835278e00af29d708e0085461c1cd79fb4050e (diff)
py: move package source into src directory
Separate the actual package source from the build files. In addition to being a bit tidier, this will prevent setup.py being erroneously installed when we introduce PEP-517 support in a later commit. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/setup.py')
-rwxr-xr-xpy/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/py/setup.py b/py/setup.py
index 8ad73e7b..d08b8b12 100755
--- a/py/setup.py
+++ b/py/setup.py
@@ -10,7 +10,7 @@ setup(name='nftables',
url='https://netfilter.org/projects/nftables/index.html',
packages=['nftables'],
provides=['nftables'],
- package_dir={'nftables':'.'},
+ package_dir={'nftables':'src'},
package_data={'nftables':['schema.json']},
classifiers=[
'Development Status :: 4 - Beta',