summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2021-02-20 16:18:03 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2021-03-02 11:08:49 +0100
commit6d085b22a8b5165406b5727ccf21a91ac5b97136 (patch)
tree6f343e53b5a6da34ee05a665b8bfd7c84605534f /src/Makefile.am
parent4722cfeed34c2333989aa88d9e0b5e4ed89f3280 (diff)
table: support for the table owner flag
Add new flag to allow userspace process to own tables: Tables that have an owner can only be updated/destroyed by the owner. The table is destroyed either if the owner process calls nft_ctx_free() or owner process is terminated (implicit table release). The ruleset listing includes the program name that owns the table: nft> list ruleset table ip x { # progname nft flags owner chain y { type filter hook input priority filter; policy accept; counter packets 1 bytes 309 } } Original code to pretty print the netlink portID to program name has been extracted from the conntrack userspace utility. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3041a933..2f6d434b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -61,6 +61,7 @@ libnftables_la_SOURCES = \
netlink_delinearize.c \
misspell.c \
monitor.c \
+ owner.c \
segtree.c \
rbtree.c \
gmputil.c \