summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
author/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2006-05-23 08:41:28 +0000
committer/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2006-05-23 08:41:28 +0000
commitde6a9db8d3a687521a89690e395939d6feb24bb1 (patch)
tree8013fa32b5cfa41b6f5bc5495435129f4cc234c7 /src/Makefile.am
parent80d766e54fd9505ca009b388593056013f8db4d7 (diff)
move definition of ULOGD_LOGFILE_DEFAULT and ULOGD_CONFIGFILE to Makefile.am,
Set default config and log files based on configure. Note that these defines cannot be placed in config.h, since they depend on the prefix, which must be expanded by make. (Philip Craig)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 783f153..8093aef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,7 @@
-INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include \
+ -DULOGD_CONFIGFILE="\"$(sysconfdir)/ulogd.conf\"" \
+ -DULOGD_LOGFILE_DEFAULT="\"$(localstatedir)/log/ulogd.log\""
sbin_PROGRAMS = ulogd