summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 39abb3e..133b6ec 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -6,12 +6,13 @@ nfulnl_test_SOURCES = nfulnl_test.c
nfulnl_test_LDADD = ../src/libnetfilter_log.la
nfulnl_test_LDFLAGS = -dynamic
-nf_log_SOURCES = nf-log.c
-nf_log_LDADD = ../src/libnetfilter_log.la $(LIBMNL_LIBS)
-nf_log_LDFLAGS = -dynamic
+nf_log_SOURCES = nf-log.c
+nf_log_LDADD = ../src/libnetfilter_log.la $(LIBMNL_LIBS)
+nf_log_LDFLAGS = -dynamic
+nf_log_CPPFLAGS = $(AM_CPPFLAGS) $(LIBMNL_CFLAGS)
if BUILD_NFCT
-nf_log_LDADD += $(LIBNETFILTER_CONNTRACK_LIBS)
-nf_log_CPPFLAGS = ${AM_CPPFLAGS} ${LIBNETFILTER_CONNTRACK_CFLAGS} -DBUILD_NFCT
+nf_log_LDADD += $(LIBNETFILTER_CONNTRACK_LIBS)
+nf_log_CPPFLAGS += $(LIBNETFILTER_CONNTRACK_CFLAGS) -DBUILD_NFCT
endif
if BUILD_IPULOG