summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2023-10-19 15:00:03 +0200
committerFlorian Westphal <fw@strlen.de>2023-11-02 11:48:30 +0100
commit83512d6c2245d264f6d7657932e6fdf1fecff29a (patch)
treea78e81f88303f65ce253ae2b267297842256ec15 /Makefile.am
parent89554fe9ef1d29714d7f678dbcc6544af74adf29 (diff)
build: no recursive make for "files/**/Makefile.am"
Merge the Makefile.am under "files/" into the toplevel Makefile.am. This is a step in the effort of dropping recursive make. Signed-off-by: Thomas Haller <thaller@redhat.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 42 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b8de7bd..83f25dd8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@ ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST =
+###############################################################################
+
pkginclude_HEADERS = \
include/nftables/libnftables.h \
$(NULL)
@@ -72,11 +74,48 @@ noinst_HEADERS = \
\
$(NULL)
+###############################################################################
+
SUBDIRS = src \
- files \
doc \
examples
+###############################################################################
+
+dist_pkgdata_DATA = \
+ files/nftables/all-in-one.nft \
+ files/nftables/arp-filter.nft \
+ files/nftables/bridge-filter.nft \
+ files/nftables/inet-filter.nft \
+ files/nftables/inet-nat.nft \
+ files/nftables/ipv4-filter.nft \
+ files/nftables/ipv4-mangle.nft \
+ files/nftables/ipv4-nat.nft \
+ files/nftables/ipv4-raw.nft \
+ files/nftables/ipv6-filter.nft \
+ files/nftables/ipv6-mangle.nft \
+ files/nftables/ipv6-nat.nft \
+ files/nftables/ipv6-raw.nft \
+ files/nftables/netdev-ingress.nft \
+ $(NULL)
+
+pkgdocdir = ${docdir}/examples
+
+dist_pkgdoc_SCRIPTS = \
+ files/examples/ct_helpers.nft \
+ files/examples/load_balancing.nft \
+ files/examples/secmark.nft \
+ files/examples/sets_and_maps.nft \
+ $(NULL)
+
+pkgsysconfdir = ${sysconfdir}/nftables/osf
+
+dist_pkgsysconf_DATA = \
+ files/osf/pf.os \
+ $(NULL)
+
+###############################################################################
+
EXTRA_DIST += \
py/pyproject.toml \
py/setup.cfg \
@@ -86,6 +125,8 @@ EXTRA_DIST += \
py/src/schema.json \
$(NULL)
+###############################################################################
+
EXTRA_DIST += \
files \
tests \