summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6a199c4..d9567ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,14 +1,14 @@
dnl Process this file with autoconf to create configure.
AC_INIT([libmnl], [1.0.0-beta0])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([foreign dist-bzip2 1.6 subdir-objects])
AC_PROG_CC
AM_PROG_CC_C_O
AC_EXEEXT
-AM_PROG_LIBTOOL
+LT_INIT
AC_SUBST(LIBTOOL_DEPS)
case $target in
@@ -16,4 +16,5 @@ case $target in
*) AC_MSG_ERROR([Linux only, dude!]);;
esac
-AC_OUTPUT(Makefile src/Makefile include/Makefile include/libmnl/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg)
+AC_CONFIG_FILES([Makefile src/Makefile include/Makefile include/libmnl/Makefile examples/Makefile examples/genl/Makefile examples/netfilter/Makefile examples/rtnl/Makefile libmnl.pc doxygen.cfg])
+AC_OUTPUT