summaryrefslogtreecommitdiffstats
path: root/py/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2023-07-31 12:40:23 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2023-08-03 09:47:49 +0200
commit8ae4dc1f40aa04e499d941faca45fe7e914f0b4d (patch)
tree051a6998f355a9f33078fe3e34e726146f5c05a3 /py/Makefile.am
parentce443afc214553b9fa6f02a640a3cd2f71a23ec9 (diff)
py: use setup.cfg to configure setuptools
Setuptools has had support for declarative configuration for several years. To quote their documentation: Setuptools allows using configuration files (usually setup.cfg) to define a package’s metadata and other options that are normally supplied to the setup() function (declarative config). This approach not only allows automation scenarios but also reduces boilerplate code in some cases. Additionally, this allows us to introduce support for PEP-517-compatible build-systems. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/Makefile.am')
-rw-r--r--py/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/py/Makefile.am b/py/Makefile.am
index 4056aa61..974539fd 100644
--- a/py/Makefile.am
+++ b/py/Makefile.am
@@ -1 +1 @@
-EXTRA_DIST = setup.py src
+EXTRA_DIST = setup.cfg setup.py src