summaryrefslogtreecommitdiffstats
path: root/py/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2023-07-31 12:40:24 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2023-08-03 09:47:49 +0200
commit8e603e0f7eec7c0000344a004228a30fbf0ece5c (patch)
tree5172993c748fafc4220b2f25ade0bb4170ce4e53 /py/Makefile.am
parent8ae4dc1f40aa04e499d941faca45fe7e914f0b4d (diff)
py: add pyproject.toml to support PEP-517-compatible build-systems
This makes it possible to build and install the module without directly invoking setup.py which has been deprecated. Retain the setup.py script for backwards-compatibility. Update INSTALL to mention the new config-file. Link: https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/Makefile.am')
-rw-r--r--py/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/py/Makefile.am b/py/Makefile.am
index 974539fd..76aa082f 100644
--- a/py/Makefile.am
+++ b/py/Makefile.am
@@ -1 +1 @@
-EXTRA_DIST = setup.cfg setup.py src
+EXTRA_DIST = pyproject.toml setup.cfg setup.py src