summaryrefslogtreecommitdiffstats
path: root/py/setup.py
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2023-07-31 12:40:23 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2023-08-03 09:47:49 +0200
commit8ae4dc1f40aa04e499d941faca45fe7e914f0b4d (patch)
tree051a6998f355a9f33078fe3e34e726146f5c05a3 /py/setup.py
parentce443afc214553b9fa6f02a640a3cd2f71a23ec9 (diff)
py: use setup.cfg to configure setuptools
Setuptools has had support for declarative configuration for several years. To quote their documentation: Setuptools allows using configuration files (usually setup.cfg) to define a package’s metadata and other options that are normally supplied to the setup() function (declarative config). This approach not only allows automation scenarios but also reduces boilerplate code in some cases. Additionally, this allows us to introduce support for PEP-517-compatible build-systems. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/setup.py')
-rwxr-xr-xpy/setup.py23
1 files changed, 2 insertions, 21 deletions
diff --git a/py/setup.py b/py/setup.py
index d08b8b12..beda28e8 100755
--- a/py/setup.py
+++ b/py/setup.py
@@ -1,24 +1,5 @@
#!/usr/bin/env python
+
from setuptools import setup
-from nftables import NFTABLES_VERSION
-setup(name='nftables',
- version=NFTABLES_VERSION,
- description='Libnftables binding',
- author='Netfilter project',
- author_email='coreteam@netfilter.org',
- url='https://netfilter.org/projects/nftables/index.html',
- packages=['nftables'],
- provides=['nftables'],
- package_dir={'nftables':'src'},
- package_data={'nftables':['schema.json']},
- classifiers=[
- 'Development Status :: 4 - Beta',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python',
- 'Topic :: System :: Networking :: Firewalls',
- ],
- )
+setup()